Добро пожаловать на видео-блог, посвященный конфигурированию сетевых устройств CISCO. Здесь вы сможете посмотреть видеоуроки(высокое качество), курсы по конфигурированию. В конце каждой статьи вы так же можете скачать видеофайл с данными по уроку, курсу, а так же готовую конфигурацию, в которую вам достаточно подставить свои параметры и затем скопировать ее непосредественно в сетевое устройство CISCO. Группа vkontakte http://vkontakte.ru/club20626505

воскресенье, 18 декабря 2011 г.

Настройка GRE Tunnel

Generic Routing Encapsulation (GRE) - протокол туннелирования сетевых пакетов, разработанный фирмой Cisco. Этот протокол используется для передачи пакетов одной сети, через другую сеть. GRE туннель представляет собой соединение точка - точка, его можно считать одной из разновидностей VPN туннеля, без шифрования. Основное достоинство GRE это возможность передавать широковещательный трафик, что позволяет пропускать через такой туннель протоколы маршрутизации использующие его, IPSec туннели в чистом виде этого не могут. Так что причин для организации GRE туннеля может быть множество от банальной необходимости пробросить свою сеть через чужое IP пространство до использования протоколов OSPF, RIPv2, EGRP совместно с IPSec.

В нашем примере есть два офиса. В каждом офисе настроена своя локальная сетка. Наша задача заключается в том, чтобы связать две локальные сетки путем конфигурирования GRE Tunnel.

Основные шаги настройки GRE tunnel.
  1. Заходим в режим конфигурирования, используя команду configure terminal.
  2. Создаем виртуальный интерфейс для туннеля, используя команду interface tunnel 0
  3. Задаем ip address используя команду ip address {номер} {маска сети}
  4. Указываем интерфейс, на котором будет открыт наш туннель, tunnel source {интерфейс}
  5. Указываем ip address маршрутизатора, на котором находится другой конец туннеля tunnel destination {ip address}
  6. Повторяем аналогичные действия на другом маршрутизаторе.
Видео урок:



Настройка роутеров для нашего примера:
Маршрутизатор №1:
interface Tunnel0
ip address 10.20.20.1 255.255.255.252
tunnel source FastEthernet0/1
tunnel destination 216.4.4.2
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 216.4.4.1 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 216.4.4.2
ip route 192.168.2.0 255.255.255.0 10.20.20.2

Маршрутизатор №2:
interface Tunnel0
ip address 10.20.20.2 255.255.255.252
tunnel source FastEthernet0/1
tunnel destination 216.4.4.1
!
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 216.4.4.2 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 216.4.4.1
ip route 192.168.1.0 255.255.255.0 10.20.20.1


9 комментариев:

  1. Многие, изучаемые, вещи объясняют с помощью сложной терминологии и запутанных определений - дабы человек, который выкладает материал казался более умными среди основной массы людей. Но даже самые сложные вещи можно пояснить с помощью элементарных понятий. Что и доказывает ALEX в своем блоге.
    Когда я проходил курс CCNA, то для понимания многих механизмов необходимо было читать множество литературы. А в этих уроках все прозрачно как стекло, без воды, все по теме.

    Огромное спасибо автору!

    С ув. KiLL_You.

    ОтветитьУдалить
    Ответы
    1. Анонимный23 июля 2013 г., 7:32

      АБСОЛЮТНО СОГЛАСЕН С ЭТИМИ СЛОВАМИ!!!)

      Удалить
  2. Добрый день, на схемах неточность - для интерфейсов fa0/0 указана маска /30. Но настраивается правильная маска /24.

    ОтветитьУдалить
  3. Красава Алекс. Спасибо за твои устремления. Тима

    ОтветитьУдалить
  4. спасибо за материал!

    ОтветитьУдалить
  5. спасибо автору за тему!
    а как через туннель пробросить VLAN-ы?

    если есть возможность помочь, напиши на мэйл - seminem2006@yandex.ru

    заранее спасибо!

    ОтветитьУдалить
  6. не пингуется сеть с другой стороны, только интерфейс другой подсети на циске.

    ОтветитьУдалить
  7. а маршрутизаторы связаны между собой должны быть?или они за счёт vpn этого связываются:?

    ОтветитьУдалить