Добро пожаловать на видео-блог, посвященный конфигурированию сетевых устройств CISCO. Здесь вы сможете посмотреть видеоуроки(высокое качество), курсы по конфигурированию. В конце каждой статьи вы так же можете скачать видеофайл с данными по уроку, курсу, а так же готовую конфигурацию, в которую вам достаточно подставить свои параметры и затем скопировать ее непосредественно в сетевое устройство CISCO. Группа vkontakte http://vkontakte.ru/club20626505

воскресенье, 5 апреля 2009 г.

Настройка EIGRP

В первые годы существования компьютерных сетей, RIP был королем протоколов маршрутизации. Но по мере роста сетей, сети, достигнувшие предела в 15 переходов установленного RIP, требовали отмены этого ограничения. Поэтому стали разрабатывать другие протоколы маршрутизации. И в данном уроке мы с вами поговорим о протоколе маршрутизации EIGRP.

В отличие от RIP, который использует в качестве мертрики количество переходов, протокол маршрутизации EIGRP использует следующие параметры:
  1. Межсетевая задержка
  2. Пропускная способность
  3. Нагрузка
  4. Надежность
На основании данных параметров вычисляется метрика маршрута.

Маршрутизаторы EIGRP, как и RIP-маршрутизаторы, периодически посылают обновления своих таблиц маршрутизации непосредственно связанным с ними соседями, но расписание отправки существенно отличается. Обновления посылаются каждые 90 секунд, в отличие от 30 секунд в RIP. Если обновление не пришло в течение 270 секунд, то маршрут помечается как неактивный. Если обновление не пришло после 630 секунд, то маршрут удаляется из таблицы. Так же можно поменять таймеры обновлений с помощью команды "timers basic". 

И так для того, чтобы войти в режим конфигурирования eigrp, необходимо набрать команду "router eigrp {номер автономной системы(АС)}". АС можно рассматривать как набор сетей или сред с общим элементов маршрутизации. К автономным системам можно обращаться как к самостоятельным объектам, адресуя данные целой сети. На данном этапе вам возможно не совсем будет понятно назначение автоновных сетей, но позже, когда мы перейдем к протоколам маршрутизации внешнего шлюза, например BGP, то вам все сразу станет понятно.

Далее с помощью команды network {ip address} {EIGRP wild card bits} задается сеть, которая непосредственно подключена к маршрутизатору и о существовании которой наш маршрутизатор будет сообщать своим соседям. EIGRP wild card bits = 255.255.255.255-(маска сети). Так же с помощью команды "passive-interface" можно указать порт, в который маршрутизатор не должен отправлять обновленную таблицу маршрутизации.

Пример конфигурации:
Router(config)#router eigrp 200
Router(config-router)#network 192.168.1.0 0.0.0.255
Router(config-router)#network 192.168.2.0 0.0.0.3

Видео урок(скачать):

четверг, 2 апреля 2009 г.

Настройка RIP

RIP - один из самых первых протоколов маршрутизации, но он до сих пор используется в небольших сетях. В настоящий момент существуют две версии данного протокола. В качестве метрики используется количество переходов до нужной сети(максимальное количество переходов-15). По умолчанию маршруты обновляются каждые 30 секунд. Обновления таблицы маршрутизации отправляются только соседним маршрутизаторам. Протокол RIP версии 1 поддерживает только сети со стандартной маской сети, то есть сети класса A, B, C. RIP версии 2 в свою очередь поддерживает сети в которых используются не стандартные маски. Так же RIP версии 2 поддерживает аутентификацию.

И так, для того чтобы войти в режим конфигурирования RIP необходимо набрать команду "router rip". Далее с помощью команды "version (1|2)" можно указать какую версию протокола вы настраиваете для данного маршрутизатора(я советую всегда использовать RIP v2, так как он включает функции и RIP v1). Затем с помощью команд "network (адрес сети)" задаются  те напрямую подключенные к маршрутизаторы сети, которые маршрутизатор должен объявлять для других маршрутизаторов в вашей сети.

Основные команды:
  • router rip - вход в режим конфигурирования rip;
  • version(1|2) - версия протокола;
  • network (ip address) - адрес сети;
  • show ip route - отображение таблицы маршрутизации;
  • debug ip rip - включение режима отладки работы протокола RIP.  
Пример конфигурации:

Router(config)#router rip
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.1.0

Видео урок(скачать):


суббота, 28 марта 2009 г.

Конфигурирование статической маршрутизации

Основной функцией маршрутизаторов является маршрутизация информации из одной сети в другую. В маршрутизаторах есть таблица маршрутизации, соответственно которой маршрутизируются  данные устройством. В настоящее время существует два способа задания данной маршрутизации:
  1. Протоколы маршрутизации.
  2. Статическая маршрутизация.
Протоколы маршрутизации позволяют маршрутизаторам динамически узнавать информацию о путях из одной сети в другую. Вот некоторые из них - RIP, EIGRP, BGP, OSPF, IS-IS

Во время статической маршрутизации администратор вручную прописывает пути из одной сети в другую. Именно о статической маршрутизации рассказывается в данном уроке. 

И так для того, чтобы вручную прописать маршрут из одной сети в другую в маршрутизаторах CISCO есть команда "ip route". Синтаксис этой команды следующий:

ip route (destination ip network address) (mask) (interface/next hop ip address).

В случае, если маршрутизатор не может найти в своей таблице маршрутизации необходимой записи и не знает ничего о сети в которую необходимо направить данные, то тогда роутер отправляет данные на шлюз по умолчанию. Для того, чтобы задать шлюз по умолчанию используется следующая команда:

 ip route 0.0.0.0 0.0.0.0 (interface/ next hop ip address).

Для того, чтобы посмотреть таблицу маршрутизации, в CISCO используется команда "show ip route".

Ниже приведена конфигурация маршрутизатора, в котором задана статическая маршрутизация:

Router>enable
Router#configure terminal 
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
Router(config)#ip route 192.168.3.0 255.255.255.0 fa0/0

Примечание:
  • 192.168.1.2 - является шлюзом по умолчанию для нашего маршрутизатора.
Видео урок(скачать):


вторник, 24 марта 2009 г.

Настройка DHCP

Каждое устройство в сети должно иметь свой IP адрес. Системный администраторы дают статические адреса маршрутизаторам, серверам, принтерам и другим сетевым устройствам адрес которых должен быть постоянным. Так же можно и всем пользовательским компьютерам назначить статические IP адреса, но если пользователи постоянно перемещаются, то вам придется постоянно  менять их адреса. Чтобы автоматизировать процесс выдачи IP адресов был придумал протокол DHCP, который динамически назначает IP адрес устройства. Сейчас я расскажу как на маршрутизаторе CISCO настроить DHCP сервер:
  1. Исключаем все статические адреса(адреса маршрутизатов и серверов).
  2. Конфигурируем DHCP пул.
  3. Конфигурируем особенности DHCP пула(указываем имя домена, шлюз по умолчанию).
Вот конфигурация:

R1>enable
R1#configure terminal
R1(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.9
R1(config)#ip dhcp excluded-address 192.168.10.254
R1(config)#ip dhcp pool LAN-POOL-1
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#domain-name alexsplanet.com
R1(dhcp-config)#end

Примечание:
  1. Исключенные адреса - 192.168.10.1 - 192.168.10.9, 192.168.10.254
  2. Имя пулаLAN-POOL-1 
  3. Сеть - 192.168.10.0 255.255.255.0 
  4. Шлюз по умолчанию - 192.168.10.1 
  5. Домен - alexsplanet.com 
Видео урок(скачать):

Конфигурирование интерфейса

Если внимательно посмотреть на сетевое оборудование с тыльной стороны, то можно заметить, что каждый порт обазначен( например fa0/0, serial0/1 ). Сейчас я вам покажу как на порт fa0/0 повесить IP адрес:

Router>enable
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit

Видео урок(скачать):

Установка пароля.

Подключаемся к нашему роутеру с помощью HyperTerminal(Start-> Programs-> Accessories->Communications->HyperTerminal). Перед нами появляется командная строка. Далее путем нижеприведенных команд мы установим пароль на вход по терминальным и виртуальным линиям (с консольного порта и по telnet соответственно):

Router>enable 
Router#configure terminal  
Router(config)#service password-encryption  
Router(config)#line con 0
Router(config-line)#password alexs  
Router(config-line)#login  
Router(config-line)#exit
Router(config)#line vty 0 4
Router(config-line)#password planet
Router(config-line)#login
Router(config-line)#exit
Router(config)#enable secret alexsplanet  

Примечание: 
  1. Пароль alexs - вход с консольного порта.
  2. Пароль planet - вход по telnet.
  3. Пароль alexsplanet - вход в привелигированный режим.
Видео урок(скачать):

Введение в CISCO IOS

Cisco IOS - операционная система, на которой работают маршрутизаторы  CISCO. Для начала я опишу основные команды командной строки:
  1. enable - вход в привилегированный режим.
  2. show running-config - показывает текущую настройку роутера.
  3. ping - проверяет связь с заданным сетевым устройством.
  4. configure terminal - вход в режим конфигурирования.
  5. show version - показывает версию операционной системы и различные системные ресурсы.
  6. ? - показывает все доступные команды в текущем режиме.
  7. write mem - записать текущую конфигурацию в стартовую.
Видео урок (скачать):

Что такое CISCO.


Привет всем! В наши дни очень сложно представить свою жизнь без интернета. Он помогает нам общаться, делится своими фотографиями с друзьями, выкладывать видео файлы и находить необходимую нам информацию. Поэтому сетевые технологии в наши дни приобретают все большую популярность. И одним из лидеров в разработке сетевого оборудования на  сегодняшний день является компания CISCO


В 1984 году Сэндли Лернер и Лен Бозак объединили усилия для решения задачи совместимости компьютеров школы бизнеса и инженерного факультета Стенфордского университета. Таким образом они создали свои первые маршрутизаторы. Благодаря этому студенты школы бизнеса получили возможность обмениваться информацией. Естественно через некоторое время в двери Лернера и Бозака начали стучаться другие владельцы компьютеров, нуждавшиеся в коммуникационном оборудовании.

Так что такое CISCO сегодня? Сегодня CISCO - это компания, которая является лидером в области разработки и продажи сетевого оборудования. Около 80% всех маршрутизаторов, которые являются основой интернета, представлены маршрутизаторами CISCO. В настоящий момент CISCO поставляет сетевое оборудование для предприятий, провайдеров, небольших предприятий и для дома. Ниже приведен список оборудования и программного обеспечения.

Список оборудования:
  • Datacenter products: Nexus Switches (1000v, 2000, 4000, 5000, 7000), MDS, Unified Computing System (UCS)
  • Cisco SPA500 Series IP Phones
  • Linksys SPA900 Series IP Phones
  • Cisco Unified IP Phones (7945, 7965, 7942, 8900 series, 9900 series, 6900 series)
  • Cisco Application Control Engine (ACE): Application Delivery Controller
  • Routers, including: 837, 1000 Series, 2500 Series, 7600, 12000, 3600 Series, ASR Series and CRS-1 and CRS-3
  • Cisco Security Manager
  • Security appliances: ASA 5500, PIX 500 series
  • Unified Computing: Cisco Unified Computing System (UCS) virtual server platform: with VMWare virtualization system run servers on Cisco hardware[40]
  • Catalyst switches: Cisco Catalyst 2900 Series, Cisco Catalyst 3000 Series, Catalyst 4500, Cisco Catalyst 6500 Series
  • Collaboration systems such as Cisco TelePresence, Cisco Manufacturing Mobile Video Collaboration with Librestream, Cisco acquired Tandberg, the world leader in Telepresence systems[41]
  • VOIP: Wireless IP Phone 7920
  • CLEO: Low Earth Orbit router
  • Cisco Wireless LAN
  • Cisco Cius: a new Android-based collaboration tablet
  • Cisco Wide Area Application Services (WAAS)
  • Set Top Boxes (High Definition PVRs)- Cable/IP
Список программного обеспечения:
  • Internetwork Operating System (IOS)
  • NX-OS
  • IOS-XR
  • Cisco Active Network Abstraction
  • Cisco Fabric Manager
  • Cisco AnyConnect Secure Mobility Client
  • Cisco Systems VPN Client
  • CiscoView
  • Data Center Management and Automation – Cisco Intelligent Automation
  • Cisco Tidal Enterprise Scheduler
  • CiscoWorks Network Management software
  • Clean Access Agent, Cisco NAC Appliance
  • Cisco Eos
  • Packet Tracer, didactic network simulator
  • Cisco Network Magic Pro
  • Cisco Unified Communications Manager
  • Cisco Unified Operations Manager (CUOM) – is a NMS for voice. It features real-time monitoring of all system elements, and performs automatic discovery for the entire system and provides contextual diagnostics for troubleshooting.
  • Cisco IP Communicator
  • Cisco Quad
  • Cisco Security Manager
  • WebEx Collaboration Tools
Так же компания CISCO обладает достаточно разветвленной системой сертификации. Существует 5 сертификационных уровней: Entry, Associate, Professional, Expert, and recently Architect, так же как и 8 специализаций: Routing & Switching, Design, Network Security, Service Provider, и недавно появившиеся Service Provider Operations, Storage Networking, Voice, and Wireless. Не секрет, что системные инженеры CISCO сегодня пользуются большим спросом на рынке труда и их труд хорошо оплачивается. В настоящий момент существует большое количество курсов, посвященных сетевым технологиям и конфигурированию сетевых устройств CISCO. Все эти курсы довольно дорогостоящие, поэтому я решил создать данный видео-блог и поделится с вами своими знаниями в области конфигурирования устройств CISCO