Добро пожаловать на видео-блог, посвященный конфигурированию сетевых устройств CISCO. Здесь вы сможете посмотреть видеоуроки(высокое качество), курсы по конфигурированию. В конце каждой статьи вы так же можете скачать видеофайл с данными по уроку, курсу, а так же готовую конфигурацию, в которую вам достаточно подставить свои параметры и затем скопировать ее непосредественно в сетевое устройство CISCO. Группа vkontakte http://vkontakte.ru/club20626505

воскресенье, 18 декабря 2011 г.

Настройка GRE Tunnel

Generic Routing Encapsulation (GRE) - протокол туннелирования сетевых пакетов, разработанный фирмой Cisco. Этот протокол используется для передачи пакетов одной сети, через другую сеть. GRE туннель представляет собой соединение точка - точка, его можно считать одной из разновидностей VPN туннеля, без шифрования. Основное достоинство GRE это возможность передавать широковещательный трафик, что позволяет пропускать через такой туннель протоколы маршрутизации использующие его, IPSec туннели в чистом виде этого не могут. Так что причин для организации GRE туннеля может быть множество от банальной необходимости пробросить свою сеть через чужое IP пространство до использования протоколов OSPF, RIPv2, EGRP совместно с IPSec.

В нашем примере есть два офиса. В каждом офисе настроена своя локальная сетка. Наша задача заключается в том, чтобы связать две локальные сетки путем конфигурирования GRE Tunnel.

Основные шаги настройки GRE tunnel.
  1. Заходим в режим конфигурирования, используя команду configure terminal.
  2. Создаем виртуальный интерфейс для туннеля, используя команду interface tunnel 0
  3. Задаем ip address используя команду ip address {номер} {маска сети}
  4. Указываем интерфейс, на котором будет открыт наш туннель, tunnel source {интерфейс}
  5. Указываем ip address маршрутизатора, на котором находится другой конец туннеля tunnel destination {ip address}
  6. Повторяем аналогичные действия на другом маршрутизаторе.
Видео урок:



Настройка роутеров для нашего примера:
Маршрутизатор №1:
interface Tunnel0
ip address 10.20.20.1 255.255.255.252
tunnel source FastEthernet0/1
tunnel destination 216.4.4.2
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 216.4.4.1 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 216.4.4.2
ip route 192.168.2.0 255.255.255.0 10.20.20.2

Маршрутизатор №2:
interface Tunnel0
ip address 10.20.20.2 255.255.255.252
tunnel source FastEthernet0/1
tunnel destination 216.4.4.1
!
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 216.4.4.2 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 216.4.4.1
ip route 192.168.1.0 255.255.255.0 10.20.20.1


воскресенье, 28 ноября 2010 г.

Списки доступа (Access list)

Списки доступа (acess list) используются для управления входящими и исходящими данными. В данном уроке мы рассмотрим 2 типа списков доступа (acees list) (стандартные и расширенные).
Настраиваются списки доступа на маршрутизаторах Cisco в два этапа. Сначала создается сам список доступа (access list), то есть задаются правила, определяющие действия маршрутизатора с определенными пакетами. Затем список доступа связывается с необходимым интерфейсом. Таким образом разные списки доступа могут быть связаны с разными интерфейсами.

Каждый список доступа (access list) идентифицируется номером. Стандартным спискам доступа назначается номер из диапазона от 1 до 99, расширенному - от 100 до 199. Стандартные списки доступа прекрасно подходят для небольших сред, они позволяют запрещать или разрешать весь трафик с определенного адреса. Расширенные списки доступа позволяют настраивать правила более гибко.

Настройка списка доступа:
1) Стандартный список доступа (standart access list). Используя команду
"access-list <номер (1-99)> <действие (deny|permit)> <адрес источника>"
в режиме конфигурирования создается список доступа. Затем, используя команду
"ip access-group <номер списка доступа> in|out"
в режиме конфигурирования интерфейса список доступа связывается с интерфейсом. Правило in или out определяет к каким пакетам будет применяться это правило (к входящим или исходящим).
Пример настройки:
Router#conf term
Router(config)#access-list 10 permit 192.168.1.1 (создаем список доступа)
Router(config)#interface fa0/0
Router(config-if)#ip access-group 10 in (связываем с интерфейсом)

2) Расширенный список доступа (extended access list). Используя команду
"access-list <номер (100-199)> <действие (permit|deny)> <протокол> <адрес источника> <адрес получателя> <порт>"
создаем расширенный список доступа (extended access list). Далее с помощью команды
"ip access-group <номер списка доступа> in|out"
связываем список доступа (access list) с интерфейсом.
Пример настройки:
Router#conf term
Router(config)#access-list 110 deny icmp 192.168.1.0 0.0.0.255 host 192.168.10.1 (создаем список доступа)
Router(config)#interface fa0/0
Router(config-if)#ip access-group 110 in (связываем с интерфейсом)

понедельник, 22 ноября 2010 г.

InterVLAN routing

В данном уроке мы рассмотрим как настраивается InterVLAN routing (маршрутизация между VLAN) на маршрутизаторах cisco.

Если вы настраиваете VLAN на коммутаторе третьего уровня, то для маршрутизации между VLAN необходимо просто ввести команду ip routing на коммутаторе.

Видео урок (скачать):